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No connection could be made because the target machine actively refused it 127.0.0.1.xxxxx

Touch - About - Troubleshooting

tpos-troubleshooting-no-connection-could-be-made-because-the-target-machine-actively-refused-it-1

 

Cause      

This issue may arise as a result of one of the following:

  • An attempt was made to establish a connection with the Swiftpos Back Office and Back Office is not aware of the Touch device. This usually happens when a Touch device was previously connected to another Swiftpos Back Office instance and is now attempting to connect with a different Swiftpos Back Office.

 

Action To Be Taken      

  • Firstly:
    • In Back Office, ensure the Connect service is running. If not, start it and in Touch try to connect the Touch device by selecting the Offline menu option in the toolbar.
    • If it comes online, you are good to go. If not, try the following:
  • Secondly:
    • In Back Office: 
      • Select the POS Devices option of the Device Settings menu:
        • Delete the Touch device's entry in the grid.
        • Re-add the device by selecting the Add option.
        • Exit the screen.
      • Select the Devices option in the Administration menu.
        • Ensure the Active option is selected against the device's entry in the grid.
        • Save the changes and exit the screen.
    • In Touch:
      • If the device has not already come online, try to connect the Touch device by selecting the Offline menu option in the toolbar.
      • If it comes online, you are good to go. If not, try the following:
  • Thirdly:
    • In Back Office: 
      • Select the POS Devices option of the Device Settings menu:
        • Delete the Touch device's entry in the grid.
        • Exit the screen.
      • Select the Devices option in the Administration menu.
        • Ensure the Active option is selected against the device's entry in the grid.
        • Save the changes and exit the screen.
    • In Touch:
      • If the device has not already come online, restart Touch.
      • It should now be online.

 

End of article