Cloud

Cloud Onboard A Venue

This outlines the How To Cloud Onboard a Venue for OrderAway, TouchMini and ordering services for 3rd Party Applications (3PAs), to establish a connection to swiftpos' Cloud services.


Subjects      


What Is It?      

Cloud Onboarding establishes a secure connection between a Venue's SwiftPOS on premise application and the swiftpos cloud infrastructure.

Cloud Onboarding is needed for the following:

  • The swiftpos Gateway Client Service, which services ordering for 3rd Party Applications (3PAs).
  • The swiftpos Cloud Sync Service



Why Is It Needed?      

It's needed for components such as:

  • The swiftpos API which provides access for 3rd Party Application (3PA) integrators to connect to the swiftpos application via a Cloud API.
  • The swiftpos Gateway Client Service which services Web applications such as OrderAway, TouchMini and ordering services for 3rd Party Applications (3PAs).
  • The swiftpos Cloud Sync Service which services integrations such as Doshii.


Who Can Do It?      

Any person that has the appropriate permissions to access to the swiftpos Services > Cloud Onboarding function. Permissions are granted via swiftpos Clerk Security



When Can It Be Done?      

Cloud Onboarding should be done when:

  • A Venue wants to implement OrderAway, TouchMini and/or ordering services for 3rd Party Applications (3PAs) for the FIRST time. That is, the Venue has never connected to the swiftpos Cloud before.
  • A Venue has migrated swiftpos to a new server and/or upgraded to v10.37+ and therefore requires connections to be re-established.
  • A Venue has been licenced for the swiftpos Cloud Sync Service and requires the service to be downloaded/installed on the swiftpos server, alongside the Gateway Service.
  • A Venue is NOT running any database operations such as Re-indexing, etc. It is recommended that database operations be avoided while Onboarding. This is to ensure that the Cloud Sync Service is started successfully.


What Is Required?      

  • swiftpos v10.37+
  • Access to the email generated during the onboarding process that contains a one-time activation code. This is emailed to:

Notes...



Once Cloud Onboarding has been completed successfully, it is recommended that each of the Locations listed in the Cloud Connectivity screen are activated.


How Is It Done?      

Do as follows:

  • Start swiftpos Back Office as Administrator.
  • Navigate to Administration > Services menu.
  • Select Cloud Onboarding button.


  • Once selected, the following prompt will be displayed.


Customer Number - Displays the site's Customer Number as provided at time of Registration.
Company Name - Displays the site's Company Name as provided at time of Registration.

  • Confirm the information displayed is correct for the Venue being Cloud Onboarded.
  • Select Next. Once selected, the following prompt will be displayed:


Authentication Code - Enter the authentication code included in the Cloud Onboarding Authentication Code email sent to the Venue's registered email address

  • Enter the Authentication Code and select Next.
  • If the process completes successfully, the following prompt will be displayed:


At this point, the following will occur:

  • The swiftpos Gateway Client Service will automatically start, with the Start Mode set to Automatic. This instance of the Gateway Client Service will facilitate communication between the Venue’s swiftpos server and swiftpos Cloud Server. This will allow the swiftpos Cloud Server to be able to communicate securely to the SwiftAPI when required.
  • If the swiftpos customer has been licenced for the Cloud Syncing, the swiftpos Cloud Sync Service will be automatically downloaded, installed as a Windows service and set to automatically start. This will start to sync the Venue's swiftpos data up to the swiftpos Cloud so the data can be made available for integrations that require it.
  1. If Cloud Onboarding fails, the following prompt will be displayed:


The logs can be viewed in within Tools > Event Logs > swiftpos Applications > swiftpos SQL Application logs.

If access to DataDog is available, search it for any relevant information that may shed light on the cause.


Troubleshooting      

One of the following issues may arise when attempting to Cloud Onboard a Venue:


Unable To Onboard      

Cause      
  • If access to DataDog is available, search it for any relevant information that may shed light on the cause.
  • The Venue's registration may have expired.
Action To Be Taken      

End of article.