TouchMini

Gateway Connection Failure

 


 


Cause      

This issue may arise as a result of one of the following:

  • The Gateway Client Service is not running.
  • The SwiftPOS Touch Terminal is not running.
    • Action To Be Taken
      • Ensure the SwiftPOS Touch Terminal on the Order Master terminal is running.
      • Check the Touch log to confirm no errors are being logged when trying to start the "Self Hosted Web Server" and "Touch.Gateway.Client".
      • Try again.
  • The swiftpos Touch Terminal hasn't received a Full Update with latest configuration.
    • Action To Be Taken
      • Apply a Full Update to the terminal which is the Order Master terminal.
      • Try again.
  • NetPOS.NET which is being used by Back Office API and/or POS API isn't available/accessible.
    • Action To Be Taken
      • Review Back Office API and/or POS API logs to determine whether NetPOS.NET is accessible.
      • Check details entered for reaching NetPOS.NET to ensure they are valid based on where Back Office API is running.
      • Check the Order Master terminal is able to reach NetPOS.NET successfully and try a member lookup to confirm its operational.
  • TouchMini has reached its 20-second timeout when attempting to do one of the following:
    • Load the Tables grid
    • Submit an Order
    • Save to a Table
    • Action To Be Taken
      • Try again, and contact swiftpos support for more assistance if you continue to experience this issue.

 

End of article.