Cloud

Gateway Client Service Not Starting Successfully

The Gateway Client Service is identified in Windows by the Touch.Gateway.Client.exe application.

 


Cause      

This issue may arise as a result of one of the following:

  • The designated Orders Terminal for the selected Location has not had the Touch (SwiftPOS.Touch.exe) application started at least once in the past with the right click Run as Administrator option selected.
  • The POS API Interface (POS.Gateway.Client.exe) has not had the Port open for All users button selected to ensure a URI reservation is added in Windows to allow Touch to be able to bind to the POS API configured Port.

 


Action To Be Taken      

 


Confirm Resolution      

To confirm the issue is resolved:

 

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