Services

Gateway Client

Back Office - Services

This provides information regarding the swiftpos Gateway Client service (Touch.Gateway.Client.exe).

 


Subjects      

 


How Is It Managed?      

  • It is automatically activated when a swiftpos Location is activated for the swiftpos Cloud.
  • Once activated, the Gateway Client service can be manually started/stopped by using either the Services menu option in the Administration menu in Back Office or by right clicking the G (Gateway) services indicator in the Information bar in the bottom right of the Back Office main menu. It is recommended that the Gateway Client service's Start-up option is set to Automatic..

 


Troubleshooting     

 

Gateway Client Service Not Starting Successfully     

Cause

This issue may arise as a result of one of the following:

  • The designated Orders Terminal for the selected Location has not had the Touch (SwiftPOS.Touch.exe) application started at least once in the past with the right click Run as Administrator option selected.
  • The POS API Interface (POS.Gateway.Client.exe) has not had the Port open for All users button selected to ensure a URI reservation is added in Windows to allow Touch to be able to bind to the POS API configured Port.

Action To Be Taken


Confirm Resolution      

To confirm the issue is resolved:

 


What Is It?      

The Gateway Client service is responsible for communication between swiftpos Back Office and the swiftpos Cloud infrastructure. It will be an outbound secure amqp internet connection to the swiftpos Cloud infrastructure.

 


 

What To Consider?      

  • This service will automatically be stopped/started when a SwiftPOS Location is Activated and will also be added as a POS Interface  in Touch if it does not already exist for the Touch terminal that is configured here

 


When Is It Used?      

It is required when a Venue's swiftpos Back Office needs to communicate with swiftpos Cloud applications like OrderAway, TouchMini, etc.

 

End of article.